Avidyne Homepage
Forum Home Forum Home > Avidyne General > EXP5000 Entegra PFD
  New Posts New Posts RSS Feed - EXP5000 knob not working...
  FAQ FAQ  Forum Search   Register Register  Login Login

EXP5000 knob not working...

 Post Reply Post Reply
Author
Message
TomC View Drop Down
Newbie
Newbie


Joined: 12 Dec 2013
Location: San Antonio
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote TomC Quote  Post ReplyReply Direct Link To This Post Topic: EXP5000 knob not working...
    Posted: 12 Dec 2013 at 2:26pm
I have an EXP5000 in a 2007 Cirrus. The knob on the right side bottom that changes values for the Hdg Bug, Alt Bug, VSI bug and Baro Set is no longer working. Twisting it in any of those modes does nothing.

The only thing that works with that knob is that pressing it will sync the heading bug with the current heading...

Any thoughts? Easy to repair?!

Thanks,
Tom
Back to Top
AviJake View Drop Down
Admin Group
Admin Group


Joined: 26 Mar 2009
Location: Lincoln MA
Status: Offline
Points: 2815
Post Options Post Options   Thanks (0) Thanks(0)   Quote AviJake Quote  Post ReplyReply Direct Link To This Post Posted: 12 Dec 2013 at 8:02pm
Hi Tom,

I'll make sure Customer Support and the Avidyne Service Center are aware.  Do they have your contact info and pertinent PFD details?

If not, I suggest sending them directly to Jared Butson (jbutson@avidyne.com).   In any case, I gave them a heads up.
Steve Jacobson
sjacobson@avidyne.com
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.01
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.045 seconds.