Avidyne Homepage
Forum Home Forum Home > Avidyne General > TAS600 Systems and ADS-B
  New Posts New Posts RSS Feed - Battery Low 9900B and 9900BX
  FAQ FAQ  Forum Search   Register Register  Login Login

Battery Low 9900B and 9900BX

 Post Reply Post Reply
Author
Message
fcmbaron View Drop Down
Newbie
Newbie
Avatar

Joined: 04 Jul 2014
Location: Scottsdale
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote fcmbaron Quote  Post ReplyReply Direct Link To This Post Topic: Battery Low 9900B and 9900BX
    Posted: 04 Jul 2014 at 8:16pm
I installed a 9900B in a Cessna Skylane and the display showed "Battery Low" and "Signal Failure".
I replace the battery in the 9900B and the messages remained the same.
So, I bought a new TAS-600 with a 9900BX processor thinking the the 9900B processor was bad.
After replacing the processor with the new 9900BX the display shows "Battery Low" and "Link Failure".
There is no apparent internal battery in the 9900BX processor.  I ran a new RS-232 line from the display to the processor with no change.  I disconnected the GPS-530 display from the processor with no change.
The installation manual says the "Link Failure" message means that it is not speaking to the traffic display.
I replaced the new 9900BX processor with the original 9900B processor and now it seems the "Signal Failure" message was solved with the new external RS-232 line, but the "Battery Low" message remains.
I sure could use some advice!  Where do I look next?  Is there a battery in the display?  I am using a TAS-9000 display but I have a newer display on order.
fcmbaron
Back to Top
AviJake View Drop Down
Admin Group
Admin Group


Joined: 26 Mar 2009
Location: Lincoln MA
Status: Offline
Points: 2815
Post Options Post Options   Thanks (0) Thanks(0)   Quote AviJake Quote  Post ReplyReply Direct Link To This Post Posted: 05 Jul 2014 at 8:01am
The new processor will not work with the older display without having the display upgraded or replaced. The display also has a battery that likely needs to be replaced.  Recommend you call Avidyne Tech Support on Monday and they can get you taken care of.  
Steve Jacobson
sjacobson@avidyne.com
Back to Top
fcmbaron View Drop Down
Newbie
Newbie
Avatar

Joined: 04 Jul 2014
Location: Scottsdale
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote fcmbaron Quote  Post ReplyReply Direct Link To This Post Posted: 05 Jul 2014 at 6:19pm
Thanks for your message - the display battery was bad.
Is the link failure because the display is not compatible?
Would just the GPS-530 RS-232 connection work?
The setup on the 530 refers to TCAD.  Will that change when connected to the 9900BX?
The 9900B works fine now with the display battery and the new RS-232 line to the display.
Thanks again - I got more and better information from you than I got with 3 calls to tech support.
fcmbaron
Back to Top
AviJake View Drop Down
Admin Group
Admin Group


Joined: 26 Mar 2009
Location: Lincoln MA
Status: Offline
Points: 2815
Post Options Post Options   Thanks (0) Thanks(0)   Quote AviJake Quote  Post ReplyReply Direct Link To This Post Posted: 06 Jul 2014 at 8:08am
The link fail message using the 9900BX is due to the display being incompatible with the active TAS processor. The BX will display on the 530 via RS232 or ARINC429. As for the 530 setup we would have to look at the 530 Install Manual. I know on our MFDs we have different traffic system setup selections available i.e. TIS, TAS (Skywatch), RS232 systems (Avidyne TAS 6xx), TCAS.

If you call or email our Director of Customer Service Mike Clifford, he'd be happy to walk you through more details and hear more about your experience with Tech Support so he can provide internal training as required.

His contact info is:

321-751-8445 Office
mclifford@avidyne.com
Steve Jacobson
sjacobson@avidyne.com
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.109 seconds.